We are currently updating our support platform

Incident Report for Lean Library

Resolved

You can now contact us using the usual support@leanlibrary.com email address.
Posted Oct 06, 2025 - 15:16 UTC

Monitoring

If you experience any issues reaching us through the usual Lean Library support address, please use the temporary email below to raise a ticket: support@leanlibraryhelp.zendesk.com

Thank you for your patience while we complete this update
Posted Oct 02, 2025 - 16:34 UTC
This incident affected: Lean Library.