Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 27, 2026 - 11:00 UTC
Scheduled
We will be carrying out system maintenance today (27 February 2026) from 11:00 to 11:15 UTC. During this time, Lean Library Workspace might be expected degrated performence. If you experience any issues outside of this timeframe, please contact us at user-support@leanlibrary.com.
Posted Feb 27, 2026 - 10:59 UTC
This scheduled maintenance affected: Lean Library Workspace.